PricingBlogDocumentationDocsRegister

Connect your Bottle project to GlitchTip

The Bottle integration adds support for the Bottle Web Framework. Currently it works well with the stable version of Bottle (0.12). However, the integration with the development version (0.13) doesn't work properly.

  1. Install sentry-sdk from PyPI with the bottle extra:

    $ pip install --upgrade sentry-sdk[bottle]
    
  2. To configure the SDK, initialize it with the integration before your app has been initialized:

    import sentry_sdk
    
    from bottle import Bottle, run
    from sentry_sdk.integrations.bottle import BottleIntegration
    
    sentry_sdk.init(
        dsn="your DSN here",
        integrations=[BottleIntegration()]
    )
    
    app = Bottle()